Debian Lenny

mayo 12, 2008

I just installed Debian Lenny amd64, with 2.6.22-2 kernel, and now I can’t wait for the final release, I installed it in the laptop, and almost everything went fine, unless the Intel 3945ABG Wireless card and the Intel HDA sound, so I’m gonna show you how I made that work.

First the sound.

1. We gotta know what card we got, so we’ll run:

$ lspci | grep Audio

I got: 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

If you get something like that, then this is going to work for you.

2. Now as root we’ll add this line to sound file, mi laptop is acer, and it works this way, I’m not really sure what you have to write if you don’t have an Acer PC.

# echo options snd-hda-intel model=acer > /etc/modprobe.d/sound

3. And install the ALSA utilities:

# aptitude install alsa-source alsa-tools alsa-tools-gui alsamixergui alsa-oss

4. To finish you have to recompile the ALSA source, just typing:

# m-a a-i alsa

When you reboot, you’ll have the sound working, It pretty simple ^_^

Now the Wireless, in this part we will recompile the iwl3945 source, we can’t install ipw3945 because the ipw3945 for this kernel doesn’t have x64 support, well I haven’t found it yet, anyway, iwl3945 is newer and it’s gonna work better 😉

I tried many ways to keep my wireless working but just this worked, with etch I had ipw3945 working pretty good, but I didn’t have my video driver, I tried recompiling my kernel but It didn’t work, I did something wrong, i guess, that’s why I get Debian Lenny, well the original post is this, I’m just writing that again, but I did it just the way it says and It worked.

Preparation

To double check that you have the right hardware, you may need to update your PCI IDs. (And while you’re at it, you may as well update the USB IDs.)

 update-pciids
 update-usbids

This guide assumes that you are running a kernel version of 2.6.22 or later. If you are running Debian etch, then the 2.6.22 kernel is available from the etch-backports repository. A sample line for your /etc/apt/sources.list is as follows and at the time of writing, the package name is linux-image-2.6.22-2-686 (or -amd64).

 deb http://www.backports.org/debian etch-backports main contrib non-free

If you have edited your /etc/apt/sources.list you will need to run aptitude update. If you have installed a new kernel, you may as well reboot into that kernel before proceeding as the use of uname below assumes that you are running the kernel for which you want to compile the module.

Installation

This guide assumes that you have set the variable $KVER to contain the current version of your kernel (e.g. 2.6.22). This can be done as follows:

 KVER=$(uname -r | sed 's,-.*,,g')

Now, obtain the kernel source and headers (both appear to be necessary at this stage) along with the firmware and make sure you have the necessary compilation tools installed:

 aptitude install linux-headers-$(uname -r) linux-source-$KVER \
       firmware-iwlwifi build-essential wireless-tools

Note that the firmware-iwlwifi package is only available in lenny/sid and that you need to either add them to your /etc/apt/sources.list too, or manually download that .deb and install it using dpkg -i.

The kernel source needs to be unpacked and a symlink put in place so that the module compiles correctly:

 cd /usr/src
 tar jxf linux-source-$KVER.tar.bz2
 ln -s /usr/src/linux-source-$KVER /lib/modules/$(uname -r)/source

Now, obtain the latest module source code. At the time of writing, it was version 1.1.18 which is known to work with 2.6.22. You can check on the iwlwifi pages for the current module status.

 wget http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-1.1.18.tgz
 tar zxf iwlwifi-1.1.18.tgz

You may now compile the driver. Note that you may be required to run make twice; follow the instructions that it prints out for you.

 cd iwlwifi-1.1.18
 make
 make install

To make the module visible to your running kernel, you may like to run depmod -a.

Usage

To load the module into the kernel:

 modprobe iwl4965


Well, that's it for now, hope it helps you.
Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: